Back to overview
Degraded

Germany Minecraft #1: Connection Failure

May 21 at 04:04pm BST
Affected services
Shared Game 4 - EPYC (Minecraft)

Resolved
May 21 at 04:43pm BST

This has been resolved now.

Created
May 21 at 04:04pm BST

We're aware of the issues on Germany Minecraft #1, we've requested remote hands to look into this system.