Back to overview
Downtime
UK Shared Game 2: Unplanned Shutdown
May 02 at 09:40pm BST
Affected services
Shared Game 2 - i9 9900K (128GB)
Resolved
May 02 at 09:57pm BST
Remote hands have resolved this issue for us. Was a issue with the windows licence key.
Affected services
Shared Game 2 - i9 9900K (128GB)
Created
May 02 at 09:40pm BST
We're aware of the issues on UK Shared Game 2. Remote hands is looking into this for us.
Affected services
Shared Game 2 - i9 9900K (128GB)