Back to overview
Downtime

UK Shared Game 4: Memory Upgrade

Apr 17, 2024 at 2:13pm UTC

Resolved
Apr 17, 2024 at 3:36pm UTC

System memory was upgraded.

Created
Apr 17, 2024 at 2:13pm UTC

We've going to be adding some more memory to this system. The system will be offline for about 15-20 minutes.