Back to overview
Downtime

Main Website, Client Area, Support Tickets, Web Hosting, VDS 1 - I9 10900K, VDS 2 - Ryzen 9 5950x, VDS 3 - Ryzen 9 5950x, VDS 4 - I7 12700k, VDS 5 - Ryzen 9 5950x, VDS 6 - Ryzen 9 5950x, VPS 1 - EPYC, Shared Game 1 - EPYC, Shared Game 2 - Xeon E5 1650, Shared Game 2 - I9 9900K (AMP), and 12 other services are down

Apr 03 at 06:39pm BST
Affected services
Main Website

Resolved
Apr 03 at 07:42pm BST

VDS 4 - I7 12700k, VDS 5 - Ryzen 9 5950x, and VDS 6 - Ryzen 9 5950x recovered.

Updated
Apr 03 at 06:56pm BST

Main Website, Client Area, Support Tickets, and 8 other resources recovered.

Created
Apr 03 at 06:39pm BST

Main Website, Client Area, Support Tickets, and 11 other resources went down.