Back to overview
Degraded

B Power Feeds to Racks Fault

Feb 23, 2026 at 7:11pm UTC
Affected services
Client Dedicated Servers
Colocation Services

Resolved
Apr 3, 2026 at 6:53pm UTC

This incident has now been fully resolved and closed once again.

Following detailed on-site investigation and a further review with engineers, we are confident that the root cause has been identified as a mechanical issue within the UPS battery cabinet. Specifically, excessive pressure from mounting brackets on the battery units resulted in abnormal operating conditions affecting the battery string, which explains the repeated failures in such a short space of time.

The affected cabinet has been rectified and safely returned to service. The UPS is now operating with full battery backup functionality restored, and all systems are stable under load.

The battery mounting system has been revised to eliminate the possibility of excessive mechanical pressure being applied to the battery units, ensuring this cannot reoccur.

As part of validation, controlled drop tests were performed by removing mains and bypass inputs and allowing the UPS to operate on battery for 15 minutes. These tests completed successfully, confirming behaviour and battery performance under load.

An additional engineer will be attending site within the next week to carry out a final full health check and independently verify systems stability.

We have also off the back of this introduced changes in internal procedures, including thorough morning and evening inspections of both UPS battery cabinets to proactively check for any early signs of abnormal conditions.

We believe it is important to be transparent in situations like this and hope this level of detail provides clarity and reassurance to all our customers.

We will continue to monitor the system closely, but at this time all infrastructure is operating as expected.

Kind regards,
William Allison | CTO @ EUGameHost

Updated
Mar 25, 2026 at 2:54pm UTC

This incident has been resolved once again, the cause of the problem is still being confirmed by engineers but the battery cabient for the B Feed UPS is back in service now.

Updated
Mar 23, 2026 at 5:05pm UTC

Update #2: Following further investigation including a secondary full review of UPS system logs, SCodes and battery charging configs, all of which have been shared with our UPS engineers and the manufacturer, no definitive software or configuration fault has been identified. The UPS unit remains operational and continues to carry full load, however the battery infrastructure has been disconnected as a precautionary measure as we cannot safely reconnect it at this time. This means we are currently operating without UPS battery backup protection. An independent engineer is attending site on Wednesday and we are pursuing an urgent response from the manufacturer on why a brand new UPS can have such problems. We will continue to provide updates as this progresses.

Kind regards,
William Allison | CTO @ EUGameHost

Updated
Mar 22, 2026 at 1:03pm UTC

This incident has been reopened following a recurrence of the UPS battery issue.

The affected battery cabinet was replaced with brand new batteries approximately 3 weeks ago, all of which were individually tested and verified as healthy at the time of installation. This confirms the issue does not lie with the battery infrastructure itself and points to a hardware/software fault within the UPS unit. The affected cabinet has been isolated and we are engaging the manufacturer directly as a matter of urgency. There is no current impact to services and we will provide further updates as this progresses.

Kind regards,
William Allison | CTO @ EUGameHost

Updated
Feb 28, 2026 at 1:32pm UTC

Update 4 - RESOLVED: Following the delivery and installation of replacement components, all remedial work has now been completed. The UPS battery infrastructure has been fully restored to operational health, with all systems confirmed stable and performing within expected parameters.

All battery strings have been impedance tested using a calibrated Hioki BT3554-50 battery tester, with every cell returning healthy readings. Bus voltage has been restored to nominal float levels and the UPS is operating normally.

This incident is now closed. We will continue to monitor UPS infrastructure closely and our updated monthly visual inspection procedure remains in place going forward.

We apologise for any concern this incident may have caused and thank you for your patience throughout.

Kind regards,
William Allison | CTO @ EUGameHost

Updated
Feb 26, 2026 at 4:28pm UTC

Update 3: This incident will be fully resolved on Saturday.
The delay is due to awaiting delivery of replacement batteries. Services remain stable and under constant monitoring.

Going forward, we have also updated our procedures to include monthly UPS battery visual inspections instead of quaterly to help prevent a recurrence of this. We will provide a final confirmation update once remedial work is completed.

Kind regards,
William Allison | CTO @ EUGameHost

Updated
Feb 24, 2026 at 6:39pm UTC

Update 2: The issue has been fully identified as a faulty battery in one of our battery strings. Upon investigation, a single cell was found to have failed catastrophically. It is worth noting that these batteries were only 6 months old, making this an unexpected and very rare failure according to our UPS Techs.

As a precautionary measure and to ensure the continued reliability of our UPS infrastructure, we will be replacing all batteries in the cabinet.

The system will remain on mains power until the replacement is complete.

We apologise for any inconvenience and will provide a further update once the work has been completed.

Kind regards,
William Allison | CTO @ EUGameHost

Updated
Feb 23, 2026 at 10:25pm UTC

Update: The affected UPS battery cabinet has been isolated due to an identified battery anomaly. The UPS remains operational on mains, however battery runtime is currently unavailable for the B power feeds to Rack 5 and Tower Rack 2.

There is no active fault affecting power delivery at this time. The risk is limited to loss of battery ride-through in the event of a mains interruption.

Our UPS engineers have been scheduled to attend, investigate and remediate.

We will provide a further update once more information becomes available to us.

For users unsure of if they are affected by this, please reach out to us.

Kind regards,
Will Allison - CTO @ EUGameHost

Created
Feb 23, 2026 at 7:11pm UTC

We have noticed an issue within the B power feeds to Rack 5 and Tower Rack 2. There is a UPS issue and the load is currently unprotected from mains failure so, as a warning, we are putting this notification out in the event that the power has an issue while in bypass.